[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4675: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3817)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4677: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3817)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4678: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3817)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4679: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3817)
PocketMatrix • View topic - iPhone HelloWorld
This site is no longer active and is available for archival purposes only. Registration and login is disabled.

iPhone HelloWorld


iPhone HelloWorld

Postby Lucyberad » Apr 23, 2009 @ 11:20am

Hi,
Im having some trouble at setting up the Helloworld for iPhone.
I've follow the steps and it result in 100 errors at compiling.
I've tried with given sample (by adding directory of libraries) but it result the same: 100 errors.

Here is a screenshot of debug log:
Image

Cordialy,
Lucyberad
Last edited by Lucyberad on Apr 27, 2009 @ 2:19pm, edited 1 time in total.
Lucyberad
pm Member
 
Posts: 5
Joined: Apr 23, 2009 @ 11:09am


Postby Lucyberad » Apr 23, 2009 @ 11:45am

I give you the XCode Project folder (See attachements).
Attachments
HelloWorld.zip
The XCode project folder.
(409.67 KiB) Downloaded 286 times
Lucyberad
pm Member
 
Posts: 5
Joined: Apr 23, 2009 @ 11:09am


Postby edge » Apr 28, 2009 @ 7:02am

Hi,

I've checked your project and libedge and libedgerender are there, which is good. Also, it doesn't complain it can't find a library (which is also good). Perhaps it is using simulator libraries for a device build or vice versa?
EDGELIB: Cross-platform mobile development at your fingertips
http://www.edgelib.com
User avatar
edge
pm Member
 
Posts: 1180
Joined: Aug 22, 2005 @ 3:42pm
Location: The Netherlands


Postby Lucyberad » Apr 28, 2009 @ 4:04pm

Thanks for your answer.

I've just tried to compile it for Device and it seems working quite well...
Helloword is not write down, but the App start and Edgelib wartermark is blinking strangely... (I will check my helloworld.cpp file).
I changed nothing in source code, libraries etc... just choosed Device.

I've tried to change project property: "Base SDK" from Device 2.2 to Simulator 2.2 and it still crash in simulator.
I redo the project and it crash the same... I don't know why simulator can't Handle Edgelib and device works better.

does edgelib need different library for simulator and device? (because I think that I use the same one).

Cordially,
Lucyberad
Lucyberad
pm Member
 
Posts: 5
Joined: Apr 23, 2009 @ 11:09am


Postby edge » Apr 28, 2009 @ 9:30pm

Hi,

Yes, you need to specify different libedge.a and libedgerender.a libraries for the simulator. You can also try to make a clean build before testing.

The getting started tutorial on edgelib.com describes how to link seperate libraries when having multiple targets (device or simulator).
EDGELIB: Cross-platform mobile development at your fingertips
http://www.edgelib.com
User avatar
edge
pm Member
 
Posts: 1180
Joined: Aug 22, 2005 @ 3:42pm
Location: The Netherlands


Postby Lucyberad » Apr 29, 2009 @ 11:12am

Ok, I finally understand how to create 2 targets, compile it adding library etc...
I've redone the project (one more time) and I understand something: when you create a new target, you need to add yourself files to compile.
Because it started into a black screen with an "Unknow error" from debugger (why it can't tell there is no main or something like that?), so i added my helloworld.cpp to files to compile.
And there, I got another problem; 1995 errors (yep, i'm doing better than before ^^).
But this time I could understand why: i'm trying to compile a C++ file so XCode reject all Obj-C files...
Then it produce something ridiculous like that:
Image
(top is debugger log, down is the line where the last error is found). You can see that the "-" token from methods declaration of Obj-C is reject. If you know what can I do to handle this... I would be happy to get some help from you.

Thanks for the help you give. I'm new to iPhone Dev (i'm intially from J2ME and DirectX Csharp market ^^) and I'm think that some people are in the same case as me.

Here is the new project: http://rapidshare.com/files/227057772/H ... b.zip.html
(too big for attachements: 1,5mo)
Lucyberad
pm Member
 
Posts: 5
Joined: Apr 23, 2009 @ 11:09am


Postby Lucyberad » Apr 29, 2009 @ 4:07pm

I did'nt notice that the simulator project don't include standard library...
it's fixed now: http://rapidshare.com/files/227152272/H ... b.zip.html
But there is still 1995 errors to go...

Edit: all errors are in UIKit.h
Lucyberad
pm Member
 
Posts: 5
Joined: Apr 23, 2009 @ 11:09am


Postby edge » Apr 30, 2009 @ 9:58pm

Hi,

Please check all your headers files including UIKit.h. Then check for C++ files including that header file.

For example, you have class.cpp and class.h files, and the class.h header file includes UIKit.h. In this case the class.cpp includes the class.h header file, which in turn includes UIKit.h generating the errors.
EDGELIB: Cross-platform mobile development at your fingertips
http://www.edgelib.com
User avatar
edge
pm Member
 
Posts: 1180
Joined: Aug 22, 2005 @ 3:42pm
Location: The Netherlands


Postby jrhee » Jun 18, 2009 @ 11:45am

Hi,

I'm getting the same issue Lucy described in her first post (100 linking errors).

I copied my Edge folder contents from my PC into /Projects/Edge, and saved the tutorial result sample contents to /Projects/helloworld_iphone. I checked and confirmed that my simulator target uses the simulator libs and my device target uses the device libs. My application and build target are both set to simulator. Is there anything else I can check?

Thanks,
John
jrhee
pm Member
 
Posts: 26
Joined: Apr 7, 2008 @ 4:28pm


Postby edge » Jun 26, 2009 @ 8:13am

Hi,

Please also try to build the helloworld sample that comes with the SDK itself. If you still have linker issues, please post them. Then we can see where it fails.
EDGELIB: Cross-platform mobile development at your fingertips
http://www.edgelib.com
User avatar
edge
pm Member
 
Posts: 1180
Joined: Aug 22, 2005 @ 3:42pm
Location: The Netherlands


Return to EDGELIB


Sort


Forum Description

Powerful and affordable C++ middleware solution covering true multi-platform 2D, 3D and network features for Apple iPhone, Windows Mobile, Symbian S60, UIQ, Linux and Windows desktop.

Moderator:

edge

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

cron