[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 486: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 115: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 115: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4675: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3817)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4677: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3817)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4678: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3817)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4679: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3817)
PocketMatrix • View topic - iPhone Simulator 2.0 : Impossible to compile
Page 1 of 1

iPhone Simulator 2.0 : Impossible to compile

PostPosted: Sep 20, 2009 @ 10:32pm
by totoch
Hello,
I've just acquired the full version of Edgelib, but I cannot even get to compile any of the samples given with the library for the iPhone Device or Simulator Target. I get the same error when I try to follow the tutorial "Getting started with Iphone".
Here is the error I get with the HelloWorld project or any other project : "error: There is no SDK with the name or path 'iphoneos2.0'".
I have installed the Edgelib libraries, the iPhone SDK (2.0 AND 3.0) and I am working with XCode under a MacBook if it can be of any help for you to answer me.
If I try to change the target from simulator 2.0 to simulator 3.0, I get library dependencies errors and it looks like no Edge library is recognized (evert Edge class is shown and warned as undefined). What can I do ?
Thank you for your help,
Totoch.

PostPosted: Sep 24, 2009 @ 10:10am
by edge
Hi,

I think something went wrong with your installation. I recommend reinstalling the latest iPhone SDK and make sure to enable the option to install older iPhone SDK's (this option is in the installation program).

The EDGELIB linking errors are probably caused by using a device library for the iPhone simulator or vice versa.

PostPosted: Sep 29, 2009 @ 7:29am
by totoch
Hi Edge,
Thanks for the quick reply, by the time I figured out a way to make it work.
Now, very strangely (i though it would be easier), i'm trying to get the Helloword sample for desktop (on visual studio 2005) to work... following the Getting Started tutorial, and it's just impossible.
I get numerous errors (like... 85 errors), all saying this kind of stuff :
- 1>c:\edgelib\include\edgerender/erdr_default.h(13) : error C2065: 'NULL' : identificateur non déclaré
1>c:\edgelib\include\edgerender/erdr_default.h(47) : error C2653: 'ClassEMemory' : n'est pas un nom de classe ni d'espace de noms
1>c:\edgelib\include\edgerender/erdr_default.h(47) : error C3861: 'Copy' : identificateur introuvable
1>c:\edgelib\include\edgerender/erdr_default.h(88) : error C2653: 'ClassEMemory' : n'est pas un nom de classe ni d'espace de noms
1>c:\edgelib\include\edgerender/erdr_default.h(88) : error C3861: 'Copy' : identificateur introuvable

I don't understand. I downloaded the Platform SDK, and made all the include/lib links to the platform sdk and to the edgelib.... Any clue ?
Oh, and by the way, even when I try to run the sample directly from the samples/ directory (without creating my own project as shown in the Getting Started tutorial), it doesn't work either... I really don't have a clue. Here is the BuildLog attached to my post.
Thanks in advance for the help!

PostPosted: Sep 30, 2009 @ 2:02am
by totoch
It's kinda urgent.... thanks! :)

PostPosted: Sep 30, 2009 @ 11:17am
by edge
Hi,

It seems that you're not including edge.h or edgemain.h properly. Please make sure the source file containing EdgeMain() includes edgemain.h, and the other source files include edge.h.

Also, don't include edgerender or gldummy header files directly.

We're going to re-check the tutorial and update if necessary.

PostPosted: Sep 30, 2009 @ 5:04pm
by totoch
Hi Edge,
I can confirm you the right includes have been made (without adding edgerender, etc.) in the project settings. Also, the right includes have been made in the source code "edgemain.h" in helloworld.cpp and I just added "edge.h" in main.h (i guess that's what you meant by "the other sources"). The problem is : i still get the exact same compilation errors.
In addition, please remember I've not been only trying the tutorial but also the Helloworld/ sample given with the EdgeLib library (which contains a Visual Studio solution with all the "right" project settings and the "right" code). Both give me the same compilation errors.
If you take a look at the file I have been attaching to my previous post, you will notice that many of the errors occur from edgemain.h ... so that means the file is in fact included. It's just that it doesn't recognize ClassEDisplay, etc... Looking at my attachment (buildlog.txt) will clarify things I think.
Thank you very much.

PostPosted: Oct 2, 2009 @ 7:03am
by totoch
I just remind you that this is urgent.
Is 4-5 days really, seriously, the average delay for every answer ?

Thank you.

PostPosted: Oct 2, 2009 @ 7:56am
by edge

PostPosted: Oct 2, 2009 @ 11:32am
by edge
Dear Totoch,

In addition to Johan's comment, I would like to remind you that we provide feedback in this public forum as a free of charge service to the community. If you have urgent requests, I advise you to get a support contract in place. Please contact us at info [at] edgelib [dot] com for more information.

Wouter

PostPosted: Oct 5, 2009 @ 1:50pm
by totoch
I take note of that. Sorry if I've been hard.
Well, here is, as requested, the code. I just remind you that I tried two ways and had therefore two projects/codes (the one following the tutorial and the one directly from the Helloworld Sample that is delivered with the edgelib). I get the same errors for both. It looks like the right things are included.
It is mainly ClassEMemory, ClassEDisplay, and the NULL identifier that return errors... maybe it's a lead to follow.
Once again, thank you.
Totoch

PostPosted: Oct 5, 2009 @ 2:27pm
by totoch
Problem resolved. The installation was corrupted (sic!) and had to be reinstalled.
Thanks anyways.

PostPosted: Oct 7, 2009 @ 5:23pm
by edge