This site is no longer active and is available for archival purposes only. Registration and login is disabled.

ios5 and linker error


ios5 and linker error

Postby k4k4r0th » Apr 27, 2012 @ 3:59pm

Hi everybody,
I am trying to use edgelib with Xcode 4.3.2 and iOS 5, building for a ipod touch 4th generation.

I added the libraries and included the include directory and lib directory.
However when I compile I have 2 errors and 66 Warnings.
The 66 warnings are of the same type:
Code: Select all

ld: warning: CPU_SUBTYPE_ARM_ALL subtype is deprecated: ../../Edge/lib/iphone/libedgerender.a(somestrangelettersthatchanges.o)
1 lines; 0 keywds; 0 nums; 13 ops; 0 strs; 0 coms    Syntactic Coloring v0.4 - Dan East  

The errors are related to the linker
Code: Select all





Undefined symbols for architecture armv7:
  "__Z8EdgeMainP11EDGESTARTUP", referenced from:
      __Z10GoEdgeMainPviPl in libedge.a(edgeframe.o)
ld: symbol(s) not found for architecture armv7
clang: error: linker command failed with exit code 1 (use -v to see invocation)
5 lines; 2 keywds; 1 nums; 15 ops; 1 strs; 0 coms    Syntactic Coloring v0.4 - Dan East  


Can you help me to solve it? Is it a problem of compatibility with ios5 ?
k4k4r0th
pm Member
 
Posts: 1
Joined: Apr 27, 2012 @ 3:51pm


Return to EDGELIB


Forum Description

Powerful and affordable C++ middleware solution covering true multi-platform 2D, 3D and network features for Apple iPhone, Windows Mobile, Symbian S60, UIQ, Linux and Windows desktop.

Moderator:

edge

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

cron