This site is no longer active and is available for archival purposes only. Registration and login is disabled.

link error

link error

Postby iphonegamesapps » Jul 30, 2012 @ 10:36am

I have just tried to upgrade to 4.2 edgelib for my iphone project.
I now get the following link error.

Can you let me know how to fix it please?

Undefined symbols for architecture armv7:
"__Z13EdgeGL_RepairPv", referenced from:
__ZN13ClassEDisplay13OnContextLostEv in libedge.a(emod_dsp.o)
"__Z22MacCreateOpenGLContextPvRS_RjS1_S_i", referenced from:
__ZN15EdgeGLInterface4OpenEimmb in libplugingl1-1.a(wrap_glesmac.o)
ld: symbol(s) not found for architecture armv7
clang: error: linker command failed with exit code 1 (use -v to see invocation)
pm Member
Posts: 1
Joined: Jul 30, 2012 @ 8:40am

Re: link error

Postby edge » Aug 23, 2012 @ 11:07am

Are you sure you're not mixing libraries from different releases? You seem to be using a 4.x edgelib with a 3.x opengl plugin.
EDGELIB: Cross-platform mobile development at your fingertips
User avatar
pm Member
Posts: 1180
Joined: Aug 22, 2005 @ 3:42pm
Location: The Netherlands

Return to EDGELIB


Forum Description

Powerful and affordable C++ middleware solution covering true multi-platform 2D, 3D and network features for Apple iPhone, Windows Mobile, Symbian S60, UIQ, Linux and Windows desktop.



Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum